Programmieren von 5 Signalen mit je 3 Begriffen auf dem Uhlenbrock 63410 mit den Uhlenbrock LocoNet-Tools und der Intellibox II

  • Hallo Zusammen,


    für die Wüst von B&W muss ich einige Signale schalten. Da ich als Stellwerkskern Elekdra verwende, möchte ich einen Loconet Decoder verwenden. Das Uhlenbrock 63410 Loconet Schaltmodul. Das Modul verfügt über 20 individuell programmierbare Ausgänge.


    Ein Blick in die Bedienungsanleitung von Uhlenbrock 63410 macht schnell klar, dass man hier an der Zentrale einen ganzen Berg von CV's editieren darf. Ich muss 5 Signale mit 3 Begriffen programmieren. Das sind EINIGE CV's.


    Wie man nur mit der Zentrale z.B. 2- oder 4-Begriffige Signale Programmiert, kann man (in Englisch) auf Youtube anschauen.



    oder



    Ausserdem finde ich persönlich, das die Hersteller von solchen Modulen einen besseren Job in Sachen Bedienungsanleitung machen könnten. Ich wäre froh, um eine "Use-Case" getriebene Anleitung. Als nicht eine Anleitung, wie man CV's errechnet und wie man sie einstellt, sondern, wie ich Schritt für Schritt - mit Bildern - einen Decoder Programmiere.


    Sowas ähnliches will ich hier erstellen und wird auch in den Videos von Digitalcareline dargestellt. Da ich Faul bin und gerne meine Daten auf dem PC dokumentiere, habe ich mit die Uhlembrock Software "LocoNet-Tools" gekauft. Zusammen mit meiner Indellibox erlaubt sie ein bequemes Programmieren des Uhlenbrock 63410 - Viel schneller als es an der Zentrale gegangen wäre.
    <h2>Use Case: Programmieren von 5 Signalen mit je 3 Begriffen auf dem Uhlenbrock 63410 mit den Uhlenbrock LocoNet-Tools und der Intellibox II</h2>
    Ich gehe davon aus, dass die LocoNet-Tools installiert sind und das die Freischalt-Codes aktiviert wurden und dass das Tool die Intellbox findet.


    Das Uhlenbrock 63410 muss an den LocoNet Bus der Intellibox angeschlossen werden und mit 16V Wechselspannung versorgt werden. Im Modul befindet sich neben dem Microcontroller noch ein Spannungsregler, der alle Anschlüsse versorgt. Auf dem PC wird das LocoNet-Tool mit einem Doppelklick gestartet.



    Das Start Fenster erscheint. Wenn das Schaltmodul aktiv ist, erkennt die Zentrale und die Software das und zeigt das Modul nach Rechts gedreht und etwas farbiger an. Hier in der oberen Reihe ganz Rechts zu sehen.



    Je nach dem, wo ich mein Modul gekauft habe (neu/gebraucht), weiss ich unter umständen die Moduladresse nicht. Also kann ich mit 65535 als Adresse das allein angeschlossene Modul auslesen. Dazu die Adresse eintippen und dann auf "Programmierung ein" klicken.



    Danach auf "Modul auslesen" klicken. Nun werden alle Werte aus dem angeschlossenen Modul gelesen. Das dauert 5-20 Sekunden.



    Bei einem neuen Modul erscheinen jetzt die Default Werte, wie unten abgebildet. Also 20x Einfacher Schaltvorgang: grün auf Adressen von 199-218.


    Als erstes gebe ich oben die neue Modul-Adresse ein. Bei mir statt 65535 die 1001. Danach gehe ich unter dem ersten Ausgang - Rechts auf den "Einstellen" Button.



    Das Program bietet mir nun die drei möglichen Typen von Ausgängen an: "Weichenausgang" (also für Magnetantriebe, etc.), "Schaltausgang" (An-/Aus, Relais, etc.) und "Lichtsignal". Ich wähle Lichtsignal.



    Es gibt verschiedene Lichtsignale - und ich habe vor, 4 SBB-Zwerg Signale und 1 SBB Hauptsignal zu steuern. Diese Signal Typen entsprechen grundsätzlich dem Lichtsignal mit 3 Begriffen. Ich muss lediglich beim Anschluss mit Dioden arbeiten, damit es nicht knallt.



    Wenn ich "Lichthauptsignal mit 3 Begriffen" ausgewählt habe, kann ich rechts die Adressen auswählen. Die Erste Adresse steuert im Wechsel zwei Begriffe - Halt/Fahrt (HP0 und HP1). Die zweite Adresse steuert das schalten von Langsamfahrt (HP2) und schaltet die vorherige Adresse aus.


    Ich habe hier 751 und 752 vergeben und dann unten auf "Einstellung übernehmen" geklickt.



    Das System fragt mich, ob ich wirklich die Daten verändern will - Ich klicke "Ja".



    Wenn ich das für alle 5 Signale gemacht habe, sehe folgendes Bild. Der Uhlenbrock 63410 ist intern in Blöcken organisiert. Ich brauche für ein 3 Begriffiges Signal einen 4er Block Ausgänge. Der Block 4 bleibt frei und ich kann das nächste 3 Begriffe Signal erst auf den Ausgang 5 legen. Die Ausgänge 4, 8, 12 und 16 stehen mir nur noch als einfache "An-/Aus-Schalter" zur Verfügung. Aber immerhin.



    Die ganze Einstellerei hat keine 5 Minuten gedauert und mit "Modul speichern" werden die Informationen in das Uhlenbrock 63410 geschrieben. Unten zeigt ein blauer Segmentbalken den Fortschritt an.



    Als letztes noch ein Punkt, der etwas Kopfzerbrechen bereiten kann... Die Überblendzeiten. Lichtsignale werden im Vorbild nicht einfach An- und Ausgeschaltet, sondern die Signalbilder blenden ineinander über. Es gibt also eine kurze Zeit, wo man deutlich die ausgehende Lampe und die angehende Lampe sehen kann. In der Tabellenspalte "Weich überblenden" kann der Button "Überblendzeit" gedrückt werden. Der Dialog erscheint:



    Ich habe hier 1 Sekunde angegeben und das System hat das auf die internen 0.928 Sekunden korrigiert. Und hier kommt jetzt das Problem. Wenn ein Anwender NICHT aus Deutschland kommt also seine Tastatur auf Deutsch/Deutschland stehen hat und als Separator des Dezimalblocks KEINEN "," (Komma) hat sondern wie ich aus der Schweiz kommt, die Tastatur also auf Deutsch/Schweiz steht und der Separator ein "." (Punkt) ist, dann stürtzt das LocoNet-Tool mit einer Meldung eines Ungültigen Formats ab. Die Prgrammierer haben hier also nur regional gedacht... .


    Abhilfe: Für das Programmieren muss ich vorher in der Windows Systemsteuerung unter "Region und Sprache" das Format (unter Zusätzliche Einstellungen) für das Dezimal-Symbol von "." auf "," wechseln. Dann kann ich problemlos mit dem LocoNet-Tool arbeiten.


    ACHTUNG: Nachher wieder zurückstellen, sonst machen Excel und Co nicht mehr was man gewohnt ist!


    Nach ca. 5 Minuten hat man ein fertig programmiertes Uhlenbrock 63410 Schaltmodul, was parat ist, für den Einbau. Ich habe es noch mit 3 LED getestet und es funktionieren alle Anschlüsse. Sinnvollerweise speichert man sich die CV's als Datei und beschriftet das Modul und die Ausgänge mit einem Aufkleber, damit man nachher weiss, welcher Ausgang was macht.


    Nachtrag:
    Beim Verkabeln und Anschliessen der Signale habe ich bemerkt, dass ich einen Denkfehler gemacht habe. Die SBB-Zwergsignale entsprechen von der Logik her einem DB Vorsignal, welches freistehend ist. Also flink umkonfiguriert, ein paar Dioden wieder entfernt und fertig. Die Tests verliefen erfolgreich und irgendwann mache ich mal ein Video davon. Die Konfiguration verlief analog zu dem Oben gezeigten Ablauf und sieht nun wie folgt aus:



    Lediglich Ausgang 20 ist noch unbenutzt. Die Überblend-Effekte sehen klasse aus.


    LG,


    Axel